Asus ZenWifi AX XT8 - A two week technical review (And that 160mhz issue)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JagoUK

Regular Contributor
First the TL;DR

  • 160mhz backhaul not possible in areas of UK due to weather radar on 5.625ghz.
Channel 124 is 5.620ghz *See map below*​
This removes one of the BIG features of this product.​
I think it could be fixed, but will it?​
  • Fronthaul 5G-1 limited to channels 36-64
Backhaul 5G-2 limited to channels 100-140​
I think this is a software limitation and would be great if it is fixed to allow all channels.​

  • A lot of apps show 160mhz as only 80mhz.

  • Amazon Firesticks don't work on all 5ghz channels. If your 2.4ghz & 5ghz SSID's are the same you could be forced onto 2.4ghz causing stuttering during playback of Blu-ray rips.

  • LG TV's struggling with streaming 4k 60fps UHD rips. (100mb LAN only, 866.7mb AC Wi-Fi. Tested 4k 60fps UHD rip peaked at 110mbps)

  • 2.5gb WAN on router cannot be set to 2.5gb LAN to node, or at least not in mesh mode.


So lets get started.


My BT Home Hub 5 running OpenWRT broke, I had to revert to Vodafone’s VOX3 router but I don't like the backdoors service providers leave in and the VOX3 can’t run OpenWRT yet..

I have an RT-N66U with merlin on it but it isn’t beefy enough to serve the whole house (2.4ghz 144mb, 5ghz 300mb)

I rip my Blu-rays to a QNAP NAS without re-encoding so the most demanding films ask for 60mbps. I wanted to future-proof myself and have been looking at the bandwidth required for UHD 4k 60fps which has been hitting 110mbps.

Couple this with a family of 5 all wanting to watch their own things on their own devices despite being sat within the one room I needed. Most are tablets/phones and I wanted to get rid of the Ethernet cables running around the house.

So mesh it is. With the XT8 promising up to 4804mbps for the backhaul and 1201mbps out the fronthaul it should really hit the spot. I have been a big fan of Asus due to the RT-N66U which weighed heavily on my decision to keep with the brand.


Purchased plugged in, lets get setup.

Being a previous user of Asus I was familiar with the setup but chose to try the easy setup via the app.

I went through all the steps in the app and even chose against my normal scepticism to allow remote access for monitoring. (Previously I used OpenVPN server on the BT home hub 5 and intend to set this up at a later date)

I got the units both talking to each other and noticed the the node had a white light but the main router still had a blue flashing light.

I note another user has had this issue. Not sure what caused it but after a factory reset, setting up via web interface and not picking remote access both units setup fine.

Time to test the setup to see if it is delivering the panacea of wireless connectivity in my house.

And then the trouble begins….

Where’s my 160mhz (4804mbps) backhaul?

I found the option to enable 160mhz, and even though it accepted the settings the app I was using (WifiAnalyzer for Android on S10+) kept reporting 80mhz.


I looked in the Wi-Fi logs and got the following.

SSID: "Hidden"
RSSI: 0 dBm SNR: 0 dB noise: -88 dBm Channel: 100/80
BSSID: "Hidden" Capability: ESS RRM
Supported Rates: [ 6(b) 9 12(b) 18 24(b) 36 48 54 ]
HE Capable:
Chanspec: 5GHz channel 106 80MHz (0xe06a)
Primary channel: 100
HT Capabilities: 40Mhz SGI20 SGI40
Supported HT MCS : 0-31
Supported VHT MCS:
NSS1 Tx: 0-11 Rx: 0-11
NSS2 Tx: 0-11 Rx: 0-11
NSS3 Tx: 0-11 Rx: 0-11
NSS4 Tx: 0-11 Rx: 0-11
Supported HE MCS:
80 Mhz:
NSS1 Tx: 0-11 Rx: 0-11
NSS2 Tx: 0-11 Rx: 0-11
NSS3 Tx: 0-11 Rx: 0-11
NSS4 Tx: 0-11 Rx: 0-11
160 Mhz:
NSS1 Tx: 0-11 Rx: 0-11
NSS2 Tx: 0-11 Rx: 0-11
NSS3 Tx: 0-11 Rx: 0-11
NSS4 Tx: 0-11 Rx: 0-11

Interference Level: Acceptable
Mode : AP Only
DFS status: state In-Service Monitoring(ISM) time elapsed 13650ms radar channel cleared by DFS channel 100/80 (0xE06A)

Channel Information
----------------------------------------
Channel 100 A Band, RADAR Sensitive
Channel 104 A Band, RADAR Sensitive
Channel 108 A Band, RADAR Sensitive
Channel 112 A Band, RADAR Sensitive
Channel 116 A Band, RADAR Sensitive, Passive
Channel 120 A Band, RADAR Sensitive, Passive
Channel 124 A Band, RADAR Sensitive, Passive, Temporarily Out of Service for 31 minutes
Channel 128 A Band, RADAR Sensitive, Passive
Channel 132 A Band, RADAR Sensitive, Passive
Channel 136 A Band, RADAR Sensitive, Passive
Channel 140 A Band, RADAR Sensitive, Passive

Stations List

----------------------------------------
idx MAC Associated Authorized RSSI PHY PSM SGI STBC MUBF NSS BW Tx rate Rx rate Connect Time
"Hidden Node MAC" Yes Yes -50dBm ax No Yes Yes Yes 4 80M 1225M 1441.2M 00:00:08
Picture1.jpg



What’s going on on channel 124?

No matter what channel I manually picked, it kept pinging channel 124 and setting out of service for 31 mins. Even a reboot I’d have to wait 31mins. And more frustratingly after the 31mins I’d still be stuck on 80mhz confirmed by the bits in yellow.

I tried other channels at 80mhz, 40mhz and 20mhz and anytime they overlapped with channel 124. BANG, 31min wait.

It is worth pointing out, when Channel 124 is in it’s 31min countdown the manual channel selection gets restricted to “Auto”


Picture2.jpg



Anyway, to cut a long story short on this segment. I am in the following scenario.


For those in the UK. (And other countries)
Channel 124 (5620mhz) is the same a the Met Office Weather Radar (5625mhz) and is smack bang in the wrong place to allow 8 contiguous channels required for 160mhz on this Mesh system (Limited to channels 100-140).

If you live near any of the Radars in the attached map you are not going to be getting 160mhz bandwidth.

Picture3.jpg



Here is what I think can be done to fix the issue.

Asus give us 80+80 allowing us to skip Channel 124.

Asus open the 36-64 channels allowing us more choice on where to stick our 160mhz and can stick front end on 4 contiguous channels in the 100-140 range.

(This would work for me fine as 36-64 are not blocked for me and frustrating as 36-64 and 100-140 are available for the single 5ghz interface on my RT-N66U).

I also managed to get the router working on 160mhz by placing some kitchen foil directly between the router and the local weather radar. Unfortunately as the node has to communicate wirelessly I couldn’t block the radar on that one too.

In short. The main selling point on this mesh system cannot be used because of where I live unless ASUS or Merlin can open up the other legally available channels.
I doubt the hardware is limited to these channels and fooling around with the router I had managed to push the router onto “other” channels.
 

JagoUK

Regular Contributor
Moving on...

Wireless scanners reporting 160mhz as 80mhz

So, forgoing the above, as part of testing to confirm I could/could not get 160mhz working I found a lot of apps can’t display 160mhz when detecting this system and shows both router and node as 80mhz.


Bad apps (May or may not be related to hardware tested on)
WifiAnalyzer (open source) Android 2.1.2 – 52GS (10-29)(S10+/S20 Ultra)Shows 80mhz
Wifiman Ubiquiti 1.5.2 (S10+/S20 Ultra)Shows 80mhz
WifiAnalyzer (oglor) (S10+) Shows 80mhz
Linssid (AX200 laptop)Shows 80mhz
Inssider legacy(AX200 laptop)Shows 80mhz


The only good app I found

Inssider latest (Free subscription)(AX200 laptop)Shows 160mhz
Linux terminal(AX200 laptop)Shows 160mhz
XT8 own Wifi Log (N/A) Shows 160mhz

SSID: "Hidden"
RSSI: 0 dBm SNR: 0 dB noise: -86 dBm Channel: 124/160
BSSID: "Hidden" Capability: ESS RRM
Supported Rates: [ 6(b) 9 12(b) 18 24(b) 36 48 54 ]
HE Capable:
Chanspec: 5GHz channel 114 160MHz (0xee72)
Primary channel: 124
Stations List
----------------------------------------
idx MAC Associated Authorized RSSI PHY PSM SGI STBC MUBF NSS BW Tx rate Rx rate Connect Time
"Hidden" Yes Yes -49dBm ax No Yes Yes Yes 4 160M 2882.3M 3242.6M 00:07:06
Picture4.jpg


Just something to consider when testing as it complicated the issue!!


Talking about complications…


Amazon firestick

So I run Kodi on some Firesticks.

Normally I segment my SSID’s but to test the functionality and make this more family friendly I decided to leave 2.4ghz and 5ghz on the same SSID.

Blu-ray playback… buffer… buffer.. buffer.

Turns out although Amazon Firesticks work on 5ghz, they won’t if you have set your channel to anything but 36-48. All my neighbours were on 36-48 so I picked 52-64. Because of this they were falling back to 2.4ghz and not keeping up with the 60mbps required for some of my sons action films. (initially I had thought it was the 1950s partition wall, built just after WWII it must have been built with lead!

Anyway, I stuck the RT-N66U in that room wired back to the XT8 router giving 5ghz @ 300mbs.

LG TV

So testing my nice new 55” 4k TV, I wanted to really push it. Despite it only being 4ft from the router, I didn’t want to have a LAN cable running to it.

Turns out the LAN port is restricted to 100mb anyway (Really LG, why?) so fell short when trying to stream a UHD 4k 60fps film. Other 4K 24fps films I have tested work fine wirelessly streaming from my NAS via wireless backhaul using the inbuilt LG app.

Using Plex 4k 60fps and 24fps crash after a few mins.

Streaming these films to a laptop with an AX200 they stream and playback fine.


2.5GB WAN

One last thing, as the 160mhz wasn’t working, I really wanted to get 2.5gb working as a backhaul between the two nodes.

At one point it did show me a 2.5gb connection but I could not access the internet, so not sure if this is a bug? Sure would be nice to make the most of that 2.5gb connection for the backhaul. Especially without the 160mhz.

Picture5.png


Other little things


I had heard about 160mhz being freed up for consumers on the front haul. I’m hesitant to accept this as a promise as I have been burned before “Waiting for promised features” and it looks like chipset doesn’t support it anyway. Can connect to 160mhz backhaul for now anyway.

I seem to be having an issue where if I’m streaming a video on one device. Switching connection on another device causes the steaming video to stop or stutter briefly.

Have issues where moving from room with router in to room with node in and device sticking to other.

You can’t turn the USB 3.0 port into another LAN port. Or use it with the Dual WAN for anything other than 4g SIM/Android tethered internet. I wanted to use it as another WAN to free up the 2.5GB wan for the backhaul.

The following 2 issues have occurred on Beta FW and not checked on standard FW Everything else has happened on the standard firmware.

Turning off a Wi-Fi radio i.e. 2.4ghz doesn’t disconnect the clients and allows other clients to reconnect. (Might be a beta firmware bug)

Slow internet on wireless client devices down to 1-2mbps yet can still stream 80mbps UHD wirelessly. Inbuilt speed tester on XT8 shows full U/L D/L, wired gets full speed too.

So what do I think?

Great bit of kit, a bit expensive, a few missed opportunities with 160mhz and 2.5GB WAN port which all look like they could be fixed in software or at least improved flexibility wise. i.e. 2.5GB backhaul with 160mhz for clients.

I have connected to the wireless backhaul with AX200 and got 2.4gbps


I’m new to this forum and hope you find this useful.
 

JagoUK

Regular Contributor
Lastly i'll just add a channel guide I found on the internet but have modified it to show the channels ASUS force us to use for front and backhaul.

It would really help if they let us have 80+80 or swap front and backhaul around.

160mhz problem.png
 

JagoUK

Regular Contributor
After 4 weeks of testing, I had to return both units, as good as it is, I could not justify this kind of money for a high speed mesh system with no high speed mesh.
In the beta thread Asus seems to have written of 5ghz backhaul as too troublesome, so I will wait for wifi6e on these units.
Such a shame as these were fantastic units.

Feedback for ASUS.

  • Allow me to select all channels on 5ghz (I could on my RT-N66U).
  • Allow 80+80 on DFS channel.
  • Let me use the 2.5gb port as an Ethernet backhaul.
  • 4 gigabit ports please, 3 isn't enough. (Plus 2.5gb making 5 total Ethernet ports).
  • Consider dual 2.5gb ports to allow daisy chain backhaul/one for WAN one for backhaul.
  • Allow link aggregation for NAS (On Node too as it would be the node near my NAS as I don't keep NAS near router).

If you can release a Wifi 6e version of this mesh system with the above addressed then i'd be all for it. The units looked fantastic and I really really didn't want to send them back.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top