Can't get local addresses (dnsmasq) working, RT-AC86U w/ 384.18

eonet

New Around Here
What I'm trying to do: I'm trying to build a local network with RT-AC86U that is not connected to internet in any way. One of the computers is running a web server for test purposes and other devices are connecting to it through the router. This setup works fine if I use IP address to connect to the router.

What I haven't been able to do: I'd like to have the other devices able to connect to the web server with an address such as "test.com" instead of IP address. I've followed the instructions at https://github.com/RMerl/asuswrt-merlin.ng/wiki/Custom-domains-with-dnsmasq but I always get the "The network cable is unplugged" message when I try to access the "test.com" address.

I'm using Asuswrt-Merlin 384.18 on RT-AC86U.

Any ideas?
 

ColinTaylor

Part of the Furniture
Make sure you have turned off the WAN interface in the router's GUI. Don't just unplug the WAN socket and leave the interface enabled. (Reboot all your connect clients after changing this.)
 

eonet

New Around Here
After turning off the WAN in GUI and rebooting the router and client devices I now get "Your WAN connection has been disabled" instead of the "The network cable is unplugged" when I try to access "test.com".

By the way, I wasn't able to follow the wiki instructions 100 % because the "Forward local domain queries to upstream DNS" option wasn't found under LAN > DHCP Server but under WAN > Internet Connection. I don't know if this makes a difference or if this has changed since the wiki was last updated.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top