What's new

IGMPproxy : R7800+Voxel1.79+Kamoj1.53.b25+ISP's IPTV box

stefg73

Occasional Visitor
Hello,

i have some random freeze with this config :

R7800 in router mode
Tried RIP disabled and RIP_2M : nothing change
ISP internet box in router mode (DMZ for R7800 wan port)
ISP's IPTV box on LAN1 R7800
R7800 IGMPproxy activated
Kamoj ADguard activated (functionnal)

Randomly, the video freeze for 2-3 seconds then everything working for several minutes then freeze,...

I tried to add -d in execute of igmpproxy program (edit /sbin/cmdigmp) to activate debug mode but i see nothing except that the logs of debug stop when video freezing.
I also add "altnet x.x.x.x/x" for upstream interface (wan) (my ISP's IPs multicast servers) in cmdigmp file to make the igmpproxy.conf file

Need help please
 

R. Gerrits

Senior Member
I'm not using IGMP proxy, so can't really help.
But I'm just wondering, what is the CPU utilization during the freezes? (could it be that CPUs are at 100% during the freeze?)

Did you also try it with QoS enabled vs disabled?
Or with the network acceleration enabled vs disabled?

Do you have other devices connected to LAN2-4? (perhaps one of those is also doing some IGMP requests causing disruptions)

And I also noticed igmpproxy in firmware is pretty ancient.
Perhaps you could test with the newer igmpproxy that is in entware ?

RIP is a routing protocol. It has nothing to do with IGMP, so that explains why changing that option doesn't explain anything.
 

stefg73

Occasional Visitor
Hello and thanks R. Gerrits,

What i've tried :

- CPU utilization when freezing : peak at 51%
- QoS On or Off : Nothing change
- Network Acceleration On or Off : Nothing change
- Let only the LAN1 device connected : Nothing Change
- Upgrade (with some adaptations in /sbin/cmdigmp) igmpproxy program from entware : Nothing Change

I will try to activate -v parameter of igmpproxy program to see more verbose logs but not sure that i'm able to understand.

Thanks for your help.
 

stefg73

Occasional Visitor
Unfortunately,

the logs stops when there is a freeze...

I'm a bit disappointed and no way to solve this problem.

Any idea ?
 

stefg73

Occasional Visitor
Hi,

i think i've found the issue !

I've disabled DHCP Client for WAN interface of R7800 and surprise : 2 hours without any freeze !
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top