Padavan's Custom Firmware

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Vasquez Sanchez

New Around Here
I've had some problems with the minidlna server scanning some MKV files (might be an issue with an old version of minidlna). I'm using a Samsung Smart TV and I've always had to multiplex them. I've built these images to check if the issues if resolved and the dlna server works as expected. Please flash them at your own risk!

RT-N56U_3.4.3.9L-101-bbc02c255_ffmpeg_0.6.trx (minidlna enabled, ffmpeg v0.6 installed)
http://s000.tinyupload.com/index.php?file_id=03160816719672454910

RT-N56U_3.4.3.9L-101-bbc02c255_ffmpeg_0.11.x.trx (minidlna enabled, ffmpeg v0.11.x installed)
http://s000.tinyupload.com/index.php?file_id=04548242231238799180

and the B1 version as requested above

RT-N56UB1_3.4.3.9L-101-bbc02c255.trx (minidlna enabled, ffmpeg v0.6 installed)
http://s000.tinyupload.com/index.php?file_id=35892611474313865188
 

Nowanada

Occasional Visitor
Oh, I didn't see this thread before. Does anyone know where to get the Padavan version featured in this video?
It has nice GUI for adblock, SQM and so on. I think it comes from China, but I can't locate the source code.
 

gingerbeardman

Regular Contributor
I believe that video is from Philippines.

it's on GitHub. https://github.com/fortitudepub/padavan-newifi3

But the Chinese forks of padavan are specific to various Chinese/Asian routers that are similar to the Asus n56u series. In this instance it's the Lenovo or D-team(?) "newifi D2" (newifi3) device.

Whilst they could provide builds for the real Asus, there's no incentive and they don't. Much like there was no incentive for padavan and other Russian developers to provide builds for the Chinese devices.

So you'll have to build it yourself or find a friend to do it.
 
Last edited:

Nowanada

Occasional Visitor
I guess I'll stick with padavan-ng then. I have one problem though - I can't get QoS to work. I compiled my build with CONFIG_FIRMWARE_INCLUDE_QOS=y, uploaded the script from here: https://openrouter.info/forum/viewtopic.php?f=21&t=4605 and set my upload/download accordingly. It looks like it works, because tc qdisc show shows something like this:
Code:
qdisc fq_codel 100: dev ppp0 parent 1:10 limit 1024p flows 1024 quantum 1514 target 5.0ms interval 100.0ms ecn
But bufferbloat doesn't change. I disabled hardware NAT, checked if the interface is correct (it is ppp0), double checked my up/down config in the script, but still no effect. I see that this QoS script refers to something called IFB which also can be baked into the firmware.
Should I build again with these settings? Are they necessary?
Code:
### Include IMQ module for shapers (a bit of performance degradation). ~0.02MB
CONFIG_FIRMWARE_INCLUDE_IMQ=y

### Include IFB module for shapers. ~0.03MB
CONFIG_FIRMWARE_INCLUDE_IFB=y
Edit: I've rebuild with IFB included and now it works. Well, kind of. It sucks ;)
 
Last edited:

Nowanada

Occasional Visitor
I used to have this fw on my belkin 750db, is this still supported or is it only for the u56?
It is supported as are many other routers.

The most up to date version of Padavan (last commit was 2 days ago) can be found here: https://gitlab.com/dm38/padavan-ng
To check if your router is supported take a look at templates: https://gitlab.com/dm38/padavan-ng/-/tree/master/trunk/configs/templates
To build firmware you can use Prometheus script (Russian website, use Google Translate if needed; personally I never used it): https://4pda.ru/forum/index.php?showtopic=714487
And here's a guide that I use (it was written by Linaro I believe; I found it in the topic above and made a few corrections):
Instructions for assembling Padavan-ng firmware without using the PROMETHEUS script

I recommend using Ubuntu 18.04.
First you'll need these packages:
sudo apt update && sudo apt install autoconf automake autopoint bison build-essential doxygen flex gawk gettext git gperf libtool pkg-config zlib1g-dev libgmp3-dev libmpc-dev libmpfr-dev texinfo python-docutils help2man libncurses5-dev netcat sudo libltdl-dev time libtool-bin

Building from the console using the following commands:
1) Prepare the sources and toolchain
cd ~/
git clone --branch master --single-branch https://gitlab.com/dm38/padavan-ng.git padavan-ng
cd padavan-ng/toolchain
./build_toolchain.sh
cd ../trunk

The configs / templates directory contains folders with manufacturers . In them you will find the model you are interested in.
2) Copy the config for your model (as an example tl_wr840n-v4.config)
cp configs/templates/tplink/tl_wr840n-v4.config .config
You don't have to use the command line here - just copy tl_wr840n-v4.config to trunk folder and rename it to .config

3) We collect the firmware
./clear_tree.sh
./build_firmware.sh

The images directory will contain the firmware in the appropriate format for the device.

Attention! For TP-Link Archer C20 V1 and C2 V1 device owners! In order not to get a complete brick (only the programmer helps), do not sew the firmware via tftp without preliminary preparation! To get the firmware for tftp, you need to take the native loader for the device (for example, in the device theme in the padavan firmware assembly instructions) and "glue" it at the beginning of the firmware file you received. In simple language ArcherC20V1_tp_recovery.bin = uboot.bin + TL_C20-V1_3.4.3.9-099.bin. The size of the uboot.bin file must be exactly 131072 bytes - I recommend going to OpenWRT website and finding a guide for your router - it's explained there.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top