RT-AC86U whatsapp problem

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

nowackis

New Around Here
Hi
2 months ago I changed house and due to WiFi coverage problems I decided to purchase a second AC86U. I connected both routes using a wire backhole in Airmesh.
At the same time I had to change ISP. Not sure if that matters but new ISP does dual NAT and serves external IP using PPPoE.

Design is following:
1 NAT: on RT-AC86U from LAN 192.168.x.x to ISP address: 10.x.x.x
2 NAT: ISP does NAT from 10.x.x.x to PUBLIC IP).

My home network design:
ISP optical/wire converter connected to MAIN ASUS RT-AC86U. It has 2 wired connections:
1 wire to LAN 24 port switch (connects 6 wired devices which generate little traffic)
2 wire to second RT-AC86U router working as Airmesh

Since I moved in occasionally Whatsapp doesn't work on Android phones.
Symptoms: During a Whatsapp call a person suddenly stops hearing me but I do hear that person. The problem persist for quite few minutes. When it happens I confirm pings from android device to public IP addresses work fine. In most cases Viber call works fine.
No problem observed on Hangout, Meet, Skype and Signal.

This behavior I observe when phones are connected to the main router as well as to mesh device. To fix problem I reset to factory default both routers 2 times using button the back of devices. I also tried to disable/enable AirProtection and QoS.

I spoke with ISP and they said I'm the only single client facing this problem. When I reset the router the problem disappears but it happens again after a while.

On other forum I found info to disable NAT acceleration, but this option is not available on my router:
LAN -> Switch Control -> NAT acceleration -> Disable
It doesn't look as feasible solution becasue I have 300mbps WAN link.

I'm using the last official software release: 3.0.0.4.384_82072-gc842320

Does anyone have an idea how to troubleshoot/resolve problem?
 
Last edited:

L&LD

Part of the Furniture
Welcome to the forums.

What router do you have specifically? RT86U isn't a router model. :)
 

OzarkEdge

Part of the Furniture
Hi
2 months ago I changed house and due to WiFi coverage problems I decided to purchase a second AC86U. I connected both routes using a wire backhole in Airmesh.
At the same time I had to change ISP. Not sure if that matters but new ISP does dual NAT and serves external IP using PPPoE.

Design is following:
1 NAT: on RT-AC86U from LAN 192.168.x.x to ISP address: 10.x.x.x
2 NAT: ISP does NAT from 10.x.x.x to PUBLIC IP).

My home network design:
ISP optical/wire converter connected to MAIN ASUS RT-AC86U. It has 2 wired connections:
1 wire to LAN 24 port switch (connects 6 wired devices which generate little traffic)
2 wire to second RT-AC86U router working as Airmesh

Since I moved in occasionally Whatsapp doesn't work on Android phones.
Symptoms: During a Whatsapp call a person suddenly stops hearing me but I do hear that person. The problem persist for quite few minutes. When it happens I confirm pings from android device to public IP addresses work fine. In most cases Viber call works fine.
No problem observed on Hangout, Meet, Skype and Signal.

This behavior I observe when phones are connected to the main router as well as to mesh device. To fix problem I reset to factory default both routers 2 times using button the back of devices. I also tried to disable/enable AirProtection and QoS.

I spoke with ISP and they said I'm the only single client facing this problem. When I reset the router the problem disappears but it happens again after a while.

On other forum I found info to disable NAT acceleration, but this option is not available on my router:
LAN -> Switch Control -> NAT acceleration -> Disable
It doesn't look as feasible solution becasue I have 300mbps WAN link.

I'm using the last official software release: 3.0.0.4.384_82072-gc842320

Does anyone have an idea how to troubleshoot/resolve problem?
Can't say I follow all of the network configuration from your description, but I'll offer two thoughts...

One-way audio with a voice call suggests a routing problem on your end where the routing gets lost/dropped.

You could try disabling WAN\NAT Passthrough\SIP Passthrough on your router, but I'm not sure what protocol your app is using.

And, I wonder if it would make sense to place your AiMesh root node in AP Mode and rely on the ISP router for NAT etc.

OE
 

nowackis

New Around Here
Thanks for a prompt replay.

I struggle to understand why routing problem would occasionally only affect only whatupapp calls and rarely viber but not other type of traffic ?!

Network design is bad but this is the way local ISP assigns external IP addresses. ISP expects you to configure own LAN (which I have in 192.168.1.x/24), then you NAT your LAN to IP: 10.x.x.x which is assigned to your WAN by ISP using PPPoE. Then ISP NAT again 10.x.x.x address to external IP address.

Unfortunately this is the only ISP available, or I can order 4G modem from mobile operator :-[

ISP only assigns IP address: 10.x.x.x to WAN link so without NAT devices from LAN won't reach external resources.
I read on one forum that disabling LAN -> Switch Control -> NAT acceleration -> Disable might help but I don't have that option available.
From what I know NAT acceleration is required for WAN links higher than 100mbps...

I'm really puzzled.
 

nowackis

New Around Here
Another interesting observation which points me to the router: I have the main router located in the attic and a mesh node in the living room. When I enter the house the android phone connects to the airmesh node. Ping/trace works fine but some VoIP calls experience the aforementioned problem, but mostly whatsup. Then I'm moving to the floor so the phone roams to the main router but the problem is present all the time.

When I turned off the airmesh node the problem disappeared and the caller immediately started hearing me again. I reproduced it 2 times today.

Does someone have an idea how to rule out airmesh problems?

During the weekend I'll place the main router in the living room and 'll turn off the air-mesh node. It will create coverage gaps in house but at least it will let me to out ISP
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top